B – Agri-Net
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
SubmitStatus

Description
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem. Output For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms. Sample Input 4 0 4 9 21 4 0 8 17 9 8 0 16 21 17 16 0 Sample Output 28

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
 
using namespace std;
 
const int INF = 1<<31 - 1;
 
int edges[110][110];
int n;
long long sum;
 
void Prim(int v){
    int low[110], exist[110];//low
    int i, j, k;
    long long min;
    for(i = 0; i < n; i ++){//vlow
        exist[i] = 0;
        low[i] = edges[i][v];
    }
    exist[v] = 1;
    sum = 0;
    for(i = 0; i < n - 1; i ++){
        min = INF;
        for(j = 0; j < n; j ++){
            if(0 == exist[j] && min > low[j]){ //low
                min = low[j];
                k = j;
            }
        }
        exist[k] = 1;//
        v = k;
        sum += min;
        //
        for(j = 0; j < n; j ++){//Primlowlow
            if(0 == exist[j] && edges[j][v] < low[j])
                low[j] = edges[j][v];
        }
    }
}
 
int main(){
    int i, j;
    while(~scanf("%d", &n)){
        for(i = 0; i < n; i ++){
            for(j = 0; j < n; j ++){
                scanf("%d", &edges[i][j]);
            }
        }
        Prim(0);
        cout << sum << endl;
    }
    return 0;
}