Arbitrage
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
SubmitStatus

Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. Output For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". Sample Input 3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0 Sample Output Case 1: Yes Case 2: No map

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
 
using namespace std;
 
map<string, int>mm;
double d[40][40];
 
int main(){
    int i, j, k;
    int n, m;
    int flag;
    char tmp[100];
    double w;
    int cnt = 0;
    while(scanf("%d", &n) && n){
        for(i = 1; i <= n; i ++){
            scanf("%s", tmp);
            string str = tmp;
            mm[str] = i;
        }
        for(i = 1; i <= n; i ++)
        for(j = 1; j <= n; j ++){
            d[i][j] = -1;
            if(i == j)
                d[i][j] = 1;
        }
        scanf("%d", &m);
        for(i = 1; i <= m; i ++){
            scanf("%s", tmp);
            string str = tmp;
            int a = mm[str];
            scanf("%lf", &w);
            scanf("%s", tmp);
            str = tmp;
            int b = mm[str];
            d[a][b] = w;
        }
        for(k = 1; k <= n; k ++)
            for(i = 1; i <= n; i ++)
                for(j = 1; j <= n; j ++){
                    if(d[i][k] != -1 && d[k][j] != -1){
                        if(d[i][k] * d[k][j] > d[i][j])
                            d[i][j] = d[i][k] * d[k][j];
                    }
                }
        flag = 0;
        for(i = 1; i <= n; i ++){
            if(d[i][i] > 1.0){
                flag = 1;
                break;
            }
        }
        cnt ++;
        if(flag)
            printf("Case %d: Yes\n", cnt);
        else
            printf("Case %d: No\n", cnt);
    }
    return 0;
}