How to TypeTime Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
SubmitStatusPracticeHDU 2577

Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100. Output For each test case, you must output the smallest times of typing the key to finish typing this string. Sample Input 3 Pirates HDUacm HDUACM Sample Output 8 8 8 Hint The string Pirates, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string HDUacm, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include <iostream>
#include <cstdio>
#include <cstring>
 
using namespace std;
 
char str[110];
int dp[110][2]; //ij=0caplocks1
 
int main(){
    int t, l, i;
    cin >> t;
    while(t --){
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 0;
        dp[0][1] = 1;
        scanf("%s", str);
        l = strlen(str);
        for(i = 0; i <= l-1; i ++){ //0i-1
            if(str[i] >= 'A' && str[i] <= 'Z'){
                dp[i+1][0] = min(dp[i][0] + 2, dp[i][1] + 2);
                dp[i+1][1] = min(dp[i][0] + 2, dp[i][1] + 1);
            }
            else{
                dp[i+1][0] = min(dp[i][0] + 1, dp[i][1] + 2);
                dp[i+1][1] = min(dp[i][0] + 2, dp[i][1] + 2);
            }
        }
        cout << min(dp[l][0], dp[l][1] + 1) << endl;
    }
    return 0;
}