Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 42770 Accepted: 14582
Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct. Output Your program is to write to standard output. The first line contains one integer, which is the desired minimal number. Sample Input 5 Ab3bd Sample Output 2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include <iostream>
#include <cstdio>
#include <cstring>
 
using namespace std;
 
char str[5010];
short m[5010][5010];  //m[i][j]i j
 
int main(){
    int n;
    int i, j, k;
    while(cin >> n){
        scanf("%s", str);
        for(i = 0; i < n; i ++){
            m[i][i] = 0;
        }
        for(k = 1; k < n; k ++) //2n
        for(i = 0; i < n - k; i ++){ //m[0][k]m[n-k-1][n-1]
            if(str[i] == str[i + k])
                m[i][i + k] = m[i + 1][i - 1 + k];
            else
                m[i][i + k] = 1 + (m[i][i - 1 + k] < m[i + 1][i + k]?m[i][i - 1 + k]:m[i + 1][i + k]);
        }
        cout << m[0][n - 1] << endl;
    }
    return 0;
}