Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 29658 Accepted: 11496

Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
 
using namespace std;
 
char x[1000];
char y[1000];
 
int dp[1001][1001];
int main(){
    int a,b,i,j;
    while(scanf("%s",x)!=EOF){
        scanf("%s",y);
        a=strlen(x);
        b=strlen(y);
        //
        for(i=1;i<=a;i++)
           for(j=1;j<=b;j++){
                if(x[i-1]==y[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
           }
        cout<<dp[a][b]<<endl;
        memset(dp,0,sizeof(dp));
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));
    }
    return 0;
}