note: This article comes from the Internet. Please contact me via lethic@163.com if there is any infringement.
lethic@163.com.

E – Sliding Window
Time Limit:12000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
SubmitStatus

Description
An array of size n 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include <cstdio>
#include <cstdlib>
 
using namespace std;
 
const int MAXN = 1000010;
int a[MAXN], qup[MAXN], qdw[MAXN], ans[MAXN];
int hup, tup, hdw, tdw;
int n, len;
 
int main()
{
    scanf("%d%d", &n, &len);
    for (int i = 1; i <= n; i++)
        scanf("%d", &a[i]);;
    hup = 1; tup = 1; qup[1] = 1;
    hdw = 1; tdw = 1; qdw[1] = 1;//qupqdw
    if (len == 1) printf("%d ", a[1]);
    ans[1] = a[1];
    for (int i = 2; i <= n; i++)//
    {
        while (a[i] <= a[qup[tup]] && tup >= hup) tup--;//
        qup[++tup] = i;//i
 
        while (a[i] >= a[qdw[tdw]] && tdw >= hdw) tdw--;//    
        qdw[++tdw] = i;//i
 
        if (qup[hup] <= i - len) hup++;
        if (qdw[hdw] <= i - len) hdw++;//
        if (i >= len) printf("%d ", a[qup[hup]]);//
        ans[i] = a[qdw[hdw]];//
    }
    printf("\n");
    for (int i = len; i <= n; i++)
        printf("%d ", ans[i]);
    printf("\n");
    return 0;
}