B – Travelling
Time Limit:3000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
SubmitStatus

Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn’t want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File. Output Output the minimum fee that he should pay,or -1 if he can't find such a route. Sample Input 2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10 Sample Output 100 90 7

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <string>
 
    using namespace std;
 
    #define INF 1<<31-1
    int tri[12]= {0,1,3,9,27,81,243,729,2187,6561,19683,59049};//1220
    int dp[59050][12];
    int dig[59050][12];//i059049jdig[i][j]ij
    int edge[12][12];
 
    int main(){
        int n, m;
        int i, j;
        int ans;
        for(i = 0; i < 59050; i ++){
            int tmp = i;
            for(j = 1; j <= 10; j ++){
                dig[i][j] = tmp % 3;
                tmp = tmp/3;
            }
        }
        while(cin >> n >> m){
            ans = INF;
            for(i = 1; i <= n; i ++){
                for(j = 1; j <= n; j ++)
                    edge[i][j] = INF;
            }
            for(i = 0; i < tri[n+1]; i ++){
                for(j = 1; j <= n; j ++){
                    dp[i][j] = INF;
                }
            }
            for(i = 1; i <= 10; i ++){
                dp[tri[i]][i] = 0;//ii0
            }
            for(i = 1; i <= m; i ++){
                int a, b, c;
                scanf("%d %d %d", &a, &b, &c);
                if(edge[a][b] > c){
                    edge[a][b] = c;
                    edge[b][a] = c;
                }
            }
            for(int s = 0; s < tri[n+1]; s ++){
                int vis_all = 1;//
                for(i = 1; i <= n; i ++){
                    if(dig[s][i] == 0)
                        vis_all =0;//SiS
                    if(dp[s][i] == INF)
                        continue;
                    for(j = 1; j <= n; j ++){
                        if(i == j)
                            continue;
                        if(edge[i][j] == INF || dig[s][j] == 2)//ijijj
                            continue;
                        int ns = s + tri[j];
                        dp[ns][j] = min(dp[ns][j], dp[s][i] + edge[i][j]);
                    }
                }
                if(vis_all)
                for(j = 1; j <= n; j ++){
                    ans = min(ans, dp[s][j]);//S
                }
            }
            if(ans == INF)
                cout << "-1" << endl;
            else
                cout << ans << endl;
        }
        return 0;
    }