The Castle
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 20000/10000K (Java/Other)

Total Submission(s) : 20 Accepted Submission(s) : 13

Problem Description
1 2 3 4 5 6 7

#############################

1 # | # | # | | #

#####—#####—#—#####—#

2 # # | # # # # #

#—#####—#####—#####—#

3 # | | # # # # #

#—#########—#####—#—#

4 # # | | | | # #

#############################

(Figure 1)

# = Wall

| = No wall

– = No wall

Figure 1 shows the map of a castle.Write a program that calculates
1. how many rooms the castle has
2. how big the largest room is
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls. Input Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms. Output Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules). Sample Input 4 7 11 6 11 6 3 10 6 7 9 6 13 5 15 5 1 10 12 7 13 7 5 13 11 10 8 10 12 13 Sample Output 5 9 Source PKU 1,2,4,8 Dfs

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#define Max 52
 
using namespace std;
 
int data[Max][Max];
int vis[Max][Max];
int a,b,count=0;
int sum=0,tmp=0;
struct mod{
    int e,w,n,s;
}pas[Max][Max];
void sign(){
	int i,j;
    for(i=1;i<=a;i++)
		for(j=1;j<=b;j++){
		    if(!(data[i][j]&1))
				pas[i][j].w=1;
			if(!(data[i][j]&4))
				pas[i][j].e=1;
			if(!(data[i][j]&2))
				pas[i][j].n=1;
			if(!(data[i][j]&8))
				pas[i][j].s=1;
		}
}
void dfs(int x,int y){
    if(!x||!y||x==a+1||y==b+1||vis[x][y])
		return ;
	//int der[4][2] = {{0,1},{0,-1},{-1,0},{1,0}};
    vis[x][y]=1;
	tmp++;
	if(pas[x][y].w)
		dfs(x,y-1);
	if(pas[x][y].e)
		dfs(x,y+1);
	if(pas[x][y].n)
		dfs(x-1,y);
	if(pas[x][y].s)
		dfs(x+1,y);
}
int main(){
	int i,j;
    cin>>a>>b;
	for(i=1;i<=a;i++)
		for(j=1;j<=b;j++)
			scanf("%d",&data[i][j]);
	sign();
    for(i=1;i<=a;i++)
		for(j=1;j<=b;j++){
			//printf("aa");
		    if(vis[i][j])
				continue;
			//printf("bb");
			count++;
			dfs(i,j);
			if(tmp>sum)
				sum=tmp;
			tmp=0;
		}
	cout<<count<<endl<<sum<<endl;
    return 0;
}