Red and Black
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 20 Accepted Submission(s) : 17
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ – a black tile
‘#’ – a red tile
‘@’ – a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input
6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
…@…
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

Source
PKU

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#define Max 52
 
using namespace std;
 
int data[Max][Max];
int vis[Max][Max];
int a,b,count=0;
int sum=0,tmp=0;
struct mod{
    int e,w,n,s;
}pas[Max][Max];
void sign(){
	int i,j;
    for(i=1;i<=a;i++)
		for(j=1;j<=b;j++){
		    if(!(data[i][j]&1))
				pas[i][j].w=1;
			if(!(data[i][j]&4))
				pas[i][j].e=1;
			if(!(data[i][j]&2))
				pas[i][j].n=1;
			if(!(data[i][j]&8))
				pas[i][j].s=1;
		}
}
void dfs(int x,int y){
    if(!x||!y||x==a+1||y==b+1||vis[x][y])
		return ;
	//int der[4][2] = {{0,1},{0,-1},{-1,0},{1,0}};
    vis[x][y]=1;
	tmp++;
	if(pas[x][y].w)
		dfs(x,y-1);
	if(pas[x][y].e)
		dfs(x,y+1);
	if(pas[x][y].n)
		dfs(x-1,y);
	if(pas[x][y].s)
		dfs(x+1,y);
}
int main(){
	int i,j;
    cin>>a>>b;
	for(i=1;i<=a;i++)
		for(j=1;j<=b;j++)
			scanf("%d",&data[i][j]);
	sign();
    for(i=1;i<=a;i++)
		for(j=1;j<=b;j++){
			//printf("aa");
		    if(vis[i][j])
				continue;
			//printf("bb");
			count++;
			dfs(i,j);
			if(tmp>sum)
				sum=tmp;
			tmp=0;
		}
	cout<<count<<endl<<sum<<endl;
    return 0;
}