Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20995 Accepted: 6994

Description
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists. Input * Line 1: Two integers: T and N * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100. Output * Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1. Sample Input 5 5 1 2 20 2 3 30 3 4 20 4 5 20 1 5 100 Sample Output 90 Hint INPUT DETAILS: There are five landmarks. OUTPUT DETAILS: Bessie can get home by following trails 4, 3, 2, and 1.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
 
using namespace std;
 
#define INF 99999999
int w[20010][20010];
int e[40010];
int u[20010];
int v[20010];
int d[20010];
 
int t, n;
 
int main(){
    int i, j, k, m, ww, x, y;
    int z;
    int cnt;
    while(cin >> t >> n){
        cnt = 0;
        memset(v, 0, sizeof(v));
        memset(d, 0, sizeof(d));
        for(i = 1; i <= n; i ++)        //i
            d[i] = (i == 1 ? 0 : INF);
        for(i = 0; i < t; i ++){        //
            scanf("%d %d", &z, &y);
            scanf("%d", &w[z][y]);
            e[++cnt] = w[z][y];
            u[cnt] = z;
            v[cnt] = y;
            e[++cnt] = w[z][y];
            u[cnt] = y;
            v[cnt] = z;
        }
        for( k = 0; k < n - 1; k ++){
            for(i = 1; i <= cnt; i ++){
                x = u[i];
                y = v[i];
                if(d[x] < INF)
                    if(d[y] > d[x] + e[i])
                        d[y] = d[x] + e[i];
            }
        }
        cout << d[n] << endl;
    }
    return 0;
}

fifo

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
#define INF 1 << 31 - 1
 
int t, n;
int cnt;
int lastshow[40010];
int d[40010];
 
struct edge{
    int to;
    int wei;
    int next;
}e[40010];
 
void insert(int a, int b, int c){
    cnt ++;
    e[cnt].to = b;
    e[cnt].next = lastshow[a];
    e[cnt].wei = c;
    lastshow[a] = cnt;
}
 
queue<int> q;
bool inq[40010];
void bellmanford(){
    memset(inq, false, sizeof(inq));
    while(!q.empty()){
        q.pop();
    }
    q.push(1); //push
    while(!q.empty()){
        int x = q.front();
        q.pop();
        inq[x] = false;
        for(int i = lastshow[x]; i != -1; i = e[i].next){
            if(d[e[i].to] > d[x] + e[i].wei){
                d[e[i].to] = d[x] + e[i].wei;
                if(!inq[e[i].to]){
                    inq[e[i].to] = true;
                    q.push(e[i].to);
                }
            }
        }
    }
}
 
int main(){
    int i, j, k, m, ww, x, y;
    int z;
    int cnt;
    while(cin >> t >> n){
        cnt = 0;
        memset(lastshow, -1, sizeof(lastshow));
        for(i = 1; i <= n; i ++)        //i
            d[i] = (i == 1 ? 0 : INF);
        for(i = 0; i < t; i ++){        //
            int a, b, c;
            scanf("%d %d %d", &a, &b, &c);
            insert(a, b, c);
            insert(b, a, c);
        }
        bellmanford();
        cout << d[n] << endl;
    }
    return 0;
}