Description
As we know,the fzu AekdyCoin is famous of math,especially in the field of number theory.So,many people call him “the descendant of Chen Jingrun”,which brings him a good reputation.
AekdyCoin also plays an important role in the ACM_DIY group,many people always ask him questions about number theory.One day,all members urged him to conduct a lesson in the group.The rookie daizhenyang is extremely weak at math,so he is delighted.
However,when AekdyCoin tells us “As we know, some numbers have interesting property. For example, any even number has the property that could be divided by 2.”,daizhenyang got confused,for he don’t have the concept of divisibility.He asks other people for help,first,he randomizely writes some positive integer numbers,then you have to pick some numbers from the group,the only constraint is that if you choose number a,you can’t choose a number divides a or a number divided by a.(to illustrate the concept of divisibility),and you have to choose as many numbers as you can.
Poor daizhenyang does well in neither math nor programming.The responsibility comes to you!

Input
An integer t,indicating the number of testcases,
For every case, first a number n indicating daizhenyang has writen n numbers(n<=1000),then n numbers,all in the range of (1...2^63-1). Output The most number you can choose. Sample Input 1 3 1 2 3 Sample Output 2 Hint: If we choose 2 and 3,one is not divisible by the other,which is the most number you can choose.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
#include <iostream>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
 
using namespace std;
 
const int MAXN=1010;
int uN,vN;  //u,v
int g[MAXN][MAXN];//0~n-1
int linker[MAXN];//
bool used[MAXN]; //dfs
bool dfs(int u){
    int v;
    for(v=0;v<vN;v++)
        if(g[u][v]&&!used[v]){
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v])){//vv
                linker[v]=u;
                return true;
            }
        }
    return false;
}
 
int hungary(){
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<uN;u++){
        memset(used,0,sizeof(used));
        if(dfs(u))  res++;
    }
    return res;
}
 
bool cmp(long long a, long long b){
    return a > b;
}
 
long long num[1010];
 
int main(){
    int t;
    int n;
    int i, j;
    scanf("%d", &t);
    while(t --){
        scanf("%d", &n);
        for(i = 0; i < n; i ++){
            scanf("%I64d", &num[i]);
        }
        memset(g, 0, sizeof(g));
        sort(num, num + n, cmp);
//        for(i = 0; i < n; i ++)
//            printf("%I64d ", num[i]);
        uN = n;
        vN = n;
        for(i = 0; i < n ; i ++){
            for(j = i + 1; j < n; j ++){
                if(num[i] % num[j] == 0){
                    g[i][j] = 1;
                }
            }
        }
        int ans = n - hungary();
        printf("%d\n", ans);
    }
    return 0;
}