Girls and BoysTime Limit:5000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
SubmitStatus
Description
In the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.
Input
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects. Output For each given data set, the program should write to standard output a line containing the result. Sample Input 7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0 Sample Output 5 2 = - /2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
 
using namespace std;
 
const int MAXN=1010;
int uN,vN;  //u,v
int g[MAXN][MAXN];//0~n-1
int linker[MAXN];//
bool used[MAXN]; //dfs
bool dfs(int u){
    int v;
    for(v=0;v<vN;v++)
        if(g[u][v]&&!used[v]){
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v])){//vv
                linker[v]=u;
                return true;
            }
        }
    return false;
}
 
int hungary(){
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<uN;u++){
        memset(used,0,sizeof(used));
        if(dfs(u))  res++;
    }
    return res;
}
 
int main(){
    int n;
    int i, j;
    while(~scanf("%d", &n)){
        memset(g, 0, sizeof(g));
        uN = n;
        vN = n;
        for(i = 0; i < n; i ++){
            int a, b;
            int num;
            scanf("%d", &a);
            getchar();
            getchar();
            getchar();
            scanf("%d", &num);
            getchar();
            getchar();
            for(j = 0; j < num; j ++){
                scanf("%d", &b);
                g[a][b] = 1;
                g[b][a] = 1;
             }
        }
        int ans = n - hungary()/2;
        printf("%d\n", ans);
    }
    return 0;
}