Description
Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza’s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. A line consisting of a single 0 terminates the input. Output For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

1
2
3
double direction(point p1, point p2, point p3){//p3p1->p2
    return (p3.x - p1.x) * (p2.y - p1.y) - (p2.x - p1.x) * (p3.y - p1.y);
}
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
 
using namespace std;
 
int n, x1, x2, y1, y2;
int ans[1010];//i
int real_ans[1010];
 
struct Board{
    int xu, xl;
}board[1010];
 
struct Point{
    int x;
    int y;
}point[1010];
 
 
int jeogia(int id, int i){//
    return (board[id].xu - board[id].xl) * (point[i].y - y2) - (point[i].x - board[id].xl) * (y1 - y2);
}
 
void judge(int i){//
    int l = 1, r = n + 1, mid;
    while(l <= r){
        mid = (l + r) / 2;
        int temp1 = jeogia(mid - 1, i);
        int temp2 = jeogia(mid, i);
        if (temp2 > 0){
            if (temp1 < 0){
                ans[mid - 1]++;
                break;
            }
            else r = mid - 1;
        }
        else
            l = mid + 1;
    }
}
 
bool cmp(Board a, Board b){
    if(a.xu != b.xu)
        return a.xu < b.xu;
    else return a.xl < b.xl;
}
 
int main(){
    int m;
    int i;
    while (cin >> n && n){
        memset(ans, 0, sizeof(ans));
        memset(real_ans, 0, sizeof(real_ans));
        scanf("%d %d %d %d %d", &m, &x1, &y1, &x2, &y2);
        board[0].xu = board[0].xl = x1;
        board[n+1].xu = board[n+1].xl = x2;
        for(i = 1; i <= n; i ++){
            scanf("%d %d", &board[i].xu, &board[i].xl);
        }
        sort(board+1, board+n+1, cmp);
        for(i = 1; i <= m; i ++){
            scanf("%d %d", &point[i].x, &point[i].y);
            judge(i);
        }
        printf("Box\n");
        for(i = 0; i <= n; i ++){
            real_ans[ans[i]] ++;
        }
        for(i = 1; i <= m; i ++){
            if(real_ans[i])
                printf("%d: %d\n", i, real_ans[i]);
        }
    }
    return 0;
}